top of page

Craft, activity and play ideas

Public·28 members
Bwalya Bwalya
Bwalya Bwalya

The App Icon Set Has An Unassigned Child !!HOT!!


CLICK HERE ===== https://blltly.com/2tsJeZ





Removed the stuff from Method 1 then clicked on "Use Asset Catalog" next to "App Icons Source" under my project's General tab. That created an Images.xcassets file in my Resources folder containing an empty "BrandAsset" folder. Then I clicked on the + button and selected "App Icons & Launch Images > New tvOS AppIcon and Top Shelf Image".This created another folder called "Brand Assets" above the "BrandAsset" folder. I then dragged my two 400 x 240 and two 1280 x 768 icon layer png files to the "App Icon - Small" and "App Icon - Large" image wells (used the Front and Back ones and left the Middle one empty). Everything looked good on the image previews and the icons moved around in parallax with the lighting. However, when I deployed the App I just got a white App Icon again. I then tried dragging the "App Icon - Large" and "App Icon - Small" assets from the "Brand Assets" folder to the "BrandAsset" folder and then started getting warnings "The brand asset collection "BrandAsset" has an unassigned item "App Icon - Large" and "The brand asset collection "BrandAsset" has an unassigned item "App Icon - Small". Do I have to add something to the Info.plist file to tell it what icons to use I'm not sure what I'm supposed to assign these icons to or what I'm doing wrong here. Help !!!!!


Okay, I've figured out how to fix this. The warning about unassigned items occurs when you drag an icon to another folder. This seems to break things and appears to be a bug. What I didn't realize was that there's a section in the XCode project's Build Settings called "Asset Catalog Compiler - Options". It's under all the Apple LLVM sections so scroll nearly all the way to the bottom and you'll see it. There you can change "Asset Catalog App Icon Set Name" and "Asset Catalog Launch Image Set Name" to whatever folder name you've created in the asset catalog.


Get rid of the folders you tried creating in your Asset catalog. Then, inside of the asset catalog, create a "New tvOS App Icon and Top Shelf Image". Assign your asset to the large and small icons as you described above. Then make sure that in your project settings the App Icons Source is pointing at the "Brand Assets" folder that you created.


Did you originally start out with an app on the device without an icon Try deleting the app off the device and reinstalling it. It works this way on iPhones, Xcode doesn't always copy resources to the device so the app installs faster when debugging.


So I'm not sure why I'm getting those warnings about unassigned items in my Images.xcassets file and I'm still getting an empty white App icon on the Apple TV devkit. I've deleted the App from the device's Settings / General / Manage Storage / screen and re-deployed but still no luck !


Doesn't matter what I do. I can't get rid of those warnings about unassigned items and I can't get an icon to appear. When I select "Use Asset Catalog" next to "App Icons Source" it creates an empty "BrandAssets" folder in my asset catalog. Then if I click on this "BrandAssets" folder to select it and then hit the + button and choose "App Icons & Launch Images / New tvOS AppIcon and Top Shelf Image" it creates another folder called "Brand Assets" (with a space) inside that BrandAssets folder. Is that how it's supposed to be laid out or doesn't it matter what sub-folders icons are in I've tried deleting the entire builds folder and my App off the device and nothing helps. Still get warnings about unassigned items and still a white icon.


If I build Apple's DemoBots project for tvOS and deploy it to my devkit then their icon appears fine. However, if I then go into their asset catalog, open their "tvOS Icon" folder and drag their "App Icon - Small" folder to the trash and then create a new one from the "New tvOS App Icon and Top Shelf Image" menu, then drag that new "App Icon - Small" folder into the DemoBots "tv OS Icon" folder then I start getting the same problems - warning "The brand asset collection "tvOS Icon" has an una




About

Welcome to the group! You can connect with other members, ge...

Members

bottom of page